latest nightly doesn't like drftpd

Have a CrossFTP Client or CrossFTP Pro Client's related question for support? Post it in here.

Moderator: manage

latest nightly doesn't like drftpd

Postby gardar » Fri Oct 02, 2009 2:28 am

Just upgraded to the latest nightly 1.55a and it doesn't seem to like drftpd

Drftpd creates emptpy dirs with info from sfv files. If there is a .sfv file in a directory, drftpd looks at it and then tells if the directory includes all the files that are in the .sfv or not. The name of the empty directory can be [ 12 of 12 files = 100% complete of 586.0MB] etc.


Let's say I want to download a directory that includes a .sfv file and files that are named file.r01 file.r02 file.r03 etc. Then crossftp begins to act strangely.

[L] CWD /DIRECTORY/Some.thing/[ 12 of 12 files = 100% complete of 586.0MB]
[L] 550 /DIRECTORY/Some.thing/[ 12 of 12 files = 100% complete of 586.0MB] : File not found
[L] /DIRECTORY/Some.thing/[ 12 of 12 files = 100% complete of 586.0MB] : File not found
[L] PRET RETR /DIRECTORY/Some.thing/[ 12 of 12 files = 100% complete of 586.0MB] /file.r01
[L] 550 Requested action not taken. File unavailable.
[L] Requested action not taken. File unavailable.

It is looking for the file /DIRECTORY/Some.thing/[ 12 of 12 files = 100% complete of 586.0MB] in When it should obviously be looking for it in /DIRECTORY/Some.thing/

This happens both when ftp-ing and fxp-ing


I hope I'm explaining good enough.

This has never been a issue before, but I hope it can be fixed soon. An option to choose to skip those "sfv information" directories or just empty dirs (since it's just a empty dir) would be good too, since we don't really need to download those "sfv information" dirs.


:)


Edit: This seems to only happen on drftpd servers, I tried downloading files from a glftpd server with the same sfv checking system and it does not act the same way, it just downloads the files from the right location.
gardar
 
Posts: 49
Joined: Tue Mar 24, 2009 9:44 am

Re: latest nightly doesn't like drftpd

Postby alex » Sat Oct 03, 2009 2:48 am

Thanks very much for the feedback. This is being checked.
CrossFTP Software
http://www.crossftp.com/
alex
 
Posts: 362
Joined: Tue Aug 07, 2007 1:38 pm

Re: latest nightly doesn't like drftpd

Postby alex » Sat Oct 03, 2009 6:59 pm

This error has been solved. Please update to the latest nightly version to fix it.
CrossFTP Software
http://www.crossftp.com/
alex
 
Posts: 362
Joined: Tue Aug 07, 2007 1:38 pm

Re: latest nightly doesn't like drftpd

Postby gardar » Sun Oct 04, 2009 11:36 pm

Great!

Any thought on the skipping empty dirs option?
gardar
 
Posts: 49
Joined: Tue Mar 24, 2009 9:44 am

Re: latest nightly doesn't like drftpd

Postby alex » Mon Oct 05, 2009 2:00 am

In my opinion, the directories like [ 12 of 12 files = 100% complete of 586.0MB] are not empty ones. It is like the phantom ones that the server reports error when you try to jump in. Hence the client is not sure whether it is a server's temporary error on this dir, or it is an empty directory.

I think the better way to skip such directory is to use skip filter. Try to toggle Use Skiplist in Site Manager -> Options, and define the Global Option -> Filters -> Skip by Directories with the proper regex. The following regex works for me for the directories like [ 12 of 12 files = 100% complete of 586.0MB].

Code: Select all
\[\s\d+\sof\s\d+\sfiles?\s\=\s\d+\%\scomplete\sof\s\d+.+\].?


For detailed help for regex, please check the manual.
CrossFTP Software
http://www.crossftp.com/
alex
 
Posts: 362
Joined: Tue Aug 07, 2007 1:38 pm

Re: latest nightly doesn't like drftpd

Postby nix4me » Tue Oct 06, 2009 11:00 pm

I am also having issues with the nightly. Fired up the new nightly today and tried to login to drftpd server.

[L2] 234 AUTH TLS successful
[L2] Negotiating Security Session...
[L2] Received close_notify during handshake
[L2] Connection lost.

Version 1.53b is fine.
nix4me
 
Posts: 31
Joined: Sat Dec 22, 2007 1:18 am

Re: latest nightly doesn't like drftpd

Postby alex » Wed Oct 07, 2009 4:58 am

Recently we enhanced the server certificate checking module, which adds the hostname checking against the cert's CN, and allows to verify the public Root CAs automatically. Three verification levels are provided: Strict, Default, and Allow_All. It seems that this enhanced checking module's Default level is too strict on the private server certs, so that some server cannot work anymore. Now the Default level has been loosen a bit, and you should be able to work with the latest nightly build. It me know if it works.
CrossFTP Software
http://www.crossftp.com/
alex
 
Posts: 362
Joined: Tue Aug 07, 2007 1:38 pm

Re: latest nightly doesn't like drftpd

Postby nix4me » Thu Oct 08, 2009 1:11 am

works now. thanks
nix4me
 
Posts: 31
Joined: Sat Dec 22, 2007 1:18 am

Re: latest nightly doesn't like drftpd

Postby gardar » Thu Oct 08, 2009 2:13 am

alex wrote:In my opinion, the directories like [ 12 of 12 files = 100% complete of 586.0MB] are not empty ones. It is like the phantom ones that the server reports error when you try to jump in. Hence the client is not sure whether it is a server's temporary error on this dir, or it is an empty directory.

I think the better way to skip such directory is to use skip filter. Try to toggle Use Skiplist in Site Manager -> Options, and define the Global Option -> Filters -> Skip by Directories with the proper regex. The following regex works for me for the directories like [ 12 of 12 files = 100% complete of 586.0MB].

Code: Select all
\[\s\d+\sof\s\d+\sfiles?\s\=\s\d+\%\scomplete\sof\s\d+.+\].?


For detailed help for regex, please check the manual.



Good point! I'm going to try it out :)
gardar
 
Posts: 49
Joined: Tue Mar 24, 2009 9:44 am


Return to Client - Public Support

Who is online

Users browsing this forum: No registered users and 2 guests

cron